To integrate Barix audio products into a Milestone XProtect system the device must have loaded
the ABCL IP-Intercom firmware version 1.12 (or higher) loaded! No other firmware will work. In the XProtect Management application has to added the Barix devices first, for that open the "add Hardware Devices" in "Advanced" mode select there the Barix devices from the driver list and run the dicovery process. Thereafter restart the XProtect services.

More details are available in the Barix Milestone guide on :
http://www.barix.com/fileadmin/data/howto/Barix_Milestone_guide_v154.pdf